您的位置:首页 > 其它

POJ-3661 Running(dp)

2017-04-13 20:24 369 查看
Running

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6908 Accepted: 2572
Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion
factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches
0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.

 

Sample Input
5 2
5
3
4
2
10

Sample Output
9

Source
USACO 2008 January Silver
题意:Bessie 在n分钟时间内,每分钟可以选择走和不走,走的话疲劳值+1,不走的话疲劳值-1(当且进度疲劳值大于0时),疲劳值不能大于m,要求最远距离。
思路:
if(j <= i)

                dp[i][0] = max(dp[i][0],dp[i-j][j]);

dp[i][j] = dp[i-1][j-1] + a[i];//max(dp[i-1][j-1] + a[i],dp[i-1][j+1]);

误区:开始一直以为状态转换方程是max(dp[i-1][j-1] + a[i],dp[i-1][j+1]);,后来网上找了些题解,在http://blog.sina.com.cn/s/blog_83d1d5c701014mue.html找到了答案,就是我上面的红字部分,如果疲劳值为0了,不可能再-1了。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int N = 1e4+5;
int a
,dp
[505];
int main()
{
int n,m;
cin>>n>>m;
for(int i = 1;i <= n;i++)
scanf("%d",&a[i]);

for(int i = 1;i <= n;i++)
{
dp[i][0] = dp[i-1][0];
for(int j = 1;j <= m;j++)
{
if(j <= i)
dp[i][0] = max(dp[i][0],dp[i-j][j]);
dp[i][j] = dp[i-1][j-1] + a[i];//max(dp[i-1][j-1] + a[i],dp[i-1][j+1]);
}
}
printf("%d\n",dp
[0]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: