您的位置:首页 > 其它

POJ - 3666 —— Making the Grade —— dp

2017-04-13 10:53 295 查看
A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add
and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting
at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove
dirt at any position along the road, the total cost of modifying the road is

| A 1 - B 1| + | A 2 - B 2| + ... + | AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input
7
1
3
2
4
5
3
9


Sample Output
3


给你一串数字,每一个数字可加可减。问花最少的代价,需要多少可以将这一串数字变为单调的。。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <cmath>
#include <algorithm>

using namespace std;

#define MAX_N 100005
#define INF 0x3f3f3f3f
#define Mem(a,x) memset(a,x,sizeof(a))
#define ll long long

ll p[2005],dp[2005][2005],a[2005];
int main() {
int n;
while(~scanf("%d",&n) && n) {
Mem(dp,0);
for(int i = 1; i<=n; i++) {
scanf("%lld",&p[i]);
a[i] = p[i];
}
sort(a+1,a+n+1);
for(int i = 1; i<=n; i++) {
ll Min = dp[i-1][1];
for(int j = 1; j<=n; j++) {
Min = min(Min,dp[i-1][j]);
if(p[i]-a[j] >= 0)
dp[i][j] = p[i]-a[j]+Min;
else dp[i][j] = a[j]-p[i]+Min;
}
}
ll ans = dp
[1];
for(int i = 1; i<=n; i++) {
ans = min(dp
[i],ans);
}
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: