您的位置:首页 > 其它

hdu 3555 Bomb

2017-04-13 07:47 387 查看
Bomb

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 17730 Accepted Submission(s): 6518

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3

1

50

500

Sample Output

0

1

15

HintFrom 1 to 500, the numbers that include the sub-sequence “49” are “49”,”149”,”249”,”349”,”449”,”490”,”491”,”492”,”493”,”494”,”495”,”496”,”497”,”498”,”499”,

so the answer is 15.

Author

fatboy_cw@WHU

Source

2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

【分析】

比较基础的数位dp了…(难的我也不会做啊…)

dp[i][j][0/1]表示有i位数字,最高位为j,不包含或包含49时的数字总数

【代码】

#include<iostream>
#include<cstring>
#include<cstdio>
#define ll long long
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
ll dp[25][10][2],digit[25];
inline ll work(ll n)
{
memset(digit,0,sizeof digit);
ll i,j,k,x,len=0,ans=0;
while(n) digit[++len]=n%10,n/=10;
bool flag=0;
for(i=len;i>=1;i--)
{
fo(j,0,digit[i]-1)
{
ans+=dp[i][j][1];
if(flag ||(digit[i+1]==4 && j==9))
ans+=dp[i][j][0];
}
if(digit[i+1]==4 && digit[i]==9) flag=1;
}
return ans;
}
int main()
{
ll i,j,k,x,T,n;
dp[0][0][0]=1;
fo(i,1,20)
fo(j,0,9)
fo(x,0,9)
{
if(!(j==4 && x==9))
dp[i][j][0]+=dp[i-1][x][0];
dp[i][j][1]+=dp[i-1][x][1];
if(j==4 && x==9)
dp[i][j][1]+=dp[i-1][x][0];
}
scanf("%lld",&T);
while(T--)
{
scanf("%lld",&n);
printf("%lld\n",work(n+1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: