您的位置:首页 > 产品设计 > UI/UE

ZOJ3210-A Stack or A Queue?

2017-04-12 22:16 211 查看
A Stack or A Queue?
Time Limit: 1 Second      Memory Limit: 32768 KB

Do you know stack and queue? They're both important data structures. A stack is a "first in last out" (FILO) data structure and a queue is a "first in first out" (FIFO) one.
Here comes the problem: given the order of some integers (it is assumed that the stack and queue are both for integers) going into the structure and coming out of it, please guess what
kind of data structure it could be - stack or queue?
Notice that here we assume that none of the integers are popped out before all the integers are pushed into the structure.
Input
There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.
Each test case contains 3 lines: The first line of each test case contains only one integer N indicating the number of integers (1 <= N <= 100). The second line of each
test case contains N integers separated by a space, which are given in the order of going into the structure (that is, the first one is the earliest going in). The third line of each test case also contains Nintegers separated by a space,
whick are given in the order of coming out of the structure (the first one is the earliest coming out).
Output
For each test case, output your guess in a single line. If the structure can only be a stack, output "stack"; or if the structure can only be a queue, output "queue"; otherwise if the
structure can be either a stack or a queue, output "both", or else otherwise output "neither".
Sample Input

4
3
1 2 3
3 2 1
3
1 2 3
1 2 3
3
1 2 1
1 2 1
3
1 2 3
2 3 1


Sample Output

stack
queue
both
neither


Author: CAO, Peng
Source: The 6th Zhejiang Provincial Collegiate Programming Contest

题意:栈的特性为先进后出,队列为先进先出。由两串数的先后顺序判断它符合哪个特性

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;
#define LL long long

int main()
{
int t,a[105],b[105],n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
for(int i=1;i<=n;i++)
scanf("%d",&b[i]);
int flag1=0,flag2=0;
int i=1,j=1;
for(;i<=n;i++,j++)
if(a[i]!=b[j]) break;
if(i>n) flag1=1;
i=1,j=n;
for(;i<=n;i++,j--)
if(a[i]!=b[j]) break;
if(i>n) flag2=1;
if(flag1&&flag2) printf("both\n");
else if(flag1) printf("queue\n");
else if(flag2) printf("stack\n");
else printf("neither\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: