您的位置:首页 > 其它

ZOJ3202-Second-price Auction

2017-04-12 21:55 232 查看
Second-price Auction
Time Limit: 1 Second      Memory Limit: 32768 KB

Do you know second-price auction? It's very simple but famous. In a second-price auction, each potential buyer privately submits, perhaps in a sealed envelope or over a secure connection,
his (or her) bid for the object to the auctioneer. After receiving all the bids, the auctioneer then awards the object to the bidder with the highest bid, and charges him (or her) the amount of the second-highest bid.
Suppose you're the auctioneer and you have received all the bids, you should decide the winner and the amount of money he (or she) should pay.
Input
There are multiple test cases. The first line of input contains an integer T(T <= 100), indicating the number of test cases. Then T test cases follow.
Each test case contains two lines: The first line of each test case contains only one integer N, indicating the number of bidders. (2 <= N <= 100) The second line of
each test case contains N integers separated by a space. The i-th integer Pi indicates the i-th bidder's bid. (0 < Pi <= 60000) You may assume that the highest bid is unique.
Output
For each test case, output a line containing two integers x and y separated by a space. It indicates that the x-th bidder is the winner and the amount of money
he (or she) should pay is y.
Sample Input

2
3
3 2 1
2
4 9


Sample Output

1 2
2 4


Author: CAO, Peng
Source: The 6th Zhejiang Provincial Collegiate Programming Contest

题意:有n个投标人,最高者获得物品,并且支付第二高投标价,问中标者和他需要支付的钱

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;
#define LL long long

struct node
{
int id;
int sum;
}x[105];

bool cmp(node a,node b)
{
return a.sum>b.sum;
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&x[i].sum);
x[i].id=i;
}
sort(x+1,x+1+n,cmp);
printf("%d %d\n",x[1].id,x[2].sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: