您的位置:首页 > 其它

hdu5423 Rikka with Tree

2017-04-12 20:53 218 查看


Rikka with Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 885    Accepted Submission(s): 405


Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For a tree T,
let F(T,i) be
the distance between vertice 1 and vertice i.(The
length of each edge is 1). 

Two trees A and B are
similiar if and only if the have same number of vertices and for each i
16d72
 meet F(A,i)=F(B,i). 

Two trees A and B are
different if and only if they have different numbers of vertices or there exist an number i which
vertice i have
different fathers in tree A and
tree B when
vertice 1 is root.

Tree A is
special if and only if there doesn't exist an tree B which A and B are
different and A and B are
similiar.

Now he wants to know if a tree is special.

It is too difficult for Rikka. Can you help her?

 

Input

There are no more than 100 testcases. 

For each testcase, the first line contains a number n(1≤n≤1000).

Then n−1 lines
follow. Each line contains two numbers u,v(1≤u,v≤n) ,
which means there is an edge between u and v.

 

Output

For each testcase, if the tree is special print "YES" , otherwise print "NO".

 

Sample Input

3
1 2
2 3
4
1 2
2 3
1 4

 

Sample Output

YES
NO

HintFor the second testcase, this tree is similiar with the given tree:
4
1 2
1 4
3 4

 

Source

BestCoder Round #53

都是学长讲的:

题意:如果一个树是special的话,那么 不可能存在另外一个树使得它们两个即similiar又different!

          similiar:两棵树的各节点到根节点的距离都相同 && 两棵树又相同的节点数;

          different:两棵树的某点的父节点是不同的         or    两棵树又不同数量的结点;

分析:根据题意可得,两棵树绝对是具有相同的结点数;

          又两种情况,一种是这棵树是条链--->一定是special;

                              另一种是这可数如果深度为一------->一定是speci;

         综合两种情况:第一种情况后接第二种情况的话,那么也是special的(结合样例)

思路:就是搜索是否存在一个有相同深度的结点,并且下一个深度是没有结点存在的话就是specia;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<stack>
#include<iostream>
#include<cmath>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
typedef pair<int,int> P;
const int inf=1e9-1;
const int maxn=1010;

int G[maxn][maxn],dis[maxn],dep[maxn];

int n;
void dfs(int x,int num)
{
dis[x]=num;
for(int i=1; i<=n; i++)
{
if(G[x][i]&&!dis[i])
dfs(i,num+1);
}
}

int main()
{
while(~scanf("%d",&n))
{
int u,v;
mem(G,0),mem(dis,0),mem(dep,0);
for(int i=1; i<n; i++)
{
scanf("%d%d",&u,&v);
G[u][v]=G[v][u]=1;
}

dfs(1,1);//dfs各节点的深度;
for(int i=1; i<=n; i++)
dep[dis[i]]++;

//只有当各深度得节点数均为1或者只有最后一个深度的节点数不为1时;
int ans=0;
for(int i=1; i<=n; i++)
{
if(dep[i]==1)
ans++;
else
{
if(dep[i+1]==0)
ans=n;
break;
}
}

if(ans==n)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}


         
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu