您的位置:首页 > 其它

HDU 2795 Billboard (线段树)

2017-04-12 20:39 417 查看

Billboard

[align=left]Problem Description[/align]
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes
in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

[align=left]Input[/align]
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

[align=left]Output[/align]
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't
be put on the billboard, output "-1" for this announcement.
 

[align=left]Sample Input[/align]

3 5 5
2
4
3
3
3

 

[align=left]Sample Output[/align]

1
2
1
3
-1

题意:

有一块h*w的矩形广告板,要往上面贴广告; 
然后给n个1*wi的广告,要求把广告贴上去; 
而且要求广告要尽量往上贴并且尽量靠左; 
求第n个广告的所在的位置,不能贴则为-1;

分析:线段树求解,数组开到2w的四倍就行了,然后从h和n中选一个小的建树,初始化树节点为输入的宽度w,然后就是不断的更新树节点(从两个子节点中选择大者)。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=2e5+10;
int tmp[maxn<<2];
int h,w,n;

void build(int l,int r,int rt){
tmp[rt]=w;
if(l==r){
return ;
}

int m=(l+r)>>1;
build(l,m,rt<<1);
build(m+1,r,rt<<1|1);
}

4000
void Update(int p,int l,int r,int rt){
if(l==r){
if(tmp[rt]>=p){
printf("%d\n",l);
tmp[rt]-=p;
return ;
}
else printf("-1\n");
return ;
}

int m=(l+r)>>1;
if(tmp[rt<<1]>=p){
Update(p,l,m,rt<<1);
}
else Update(p,m+1,r,rt<<1|1);

tmp[rt]=max(tmp[rt<<1],tmp[rt<<1|1]);
}

int main(){
while(scanf("%d%d%d",&h,&w,&n)==3){
if(h>n)h=n;
build(1,h,1);

for(int i=0;i<n;i++){
int t;
scanf("%d",&t);
Update(t,1,h,1);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: