您的位置:首页 > 其它

POJ - 2752 Seek the Name, Seek the Fame(前缀和后缀子串相同 KMP)

2017-04-12 19:08 645 查看
Seek the Name, Seek the Fame POJ - 2752

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab

aaaaa

Sample Output

2 4 9 18

1 2 3 4 5

题意:给一个字符串,求前缀和后缀相同的子串的长度。

利用next跳表逆推,j=next[len] j=next[j]。直到j=0.

#include<stdio.h>
#include<string.h>
struct KMP
{
char a[2000000];
int nextval[2000000];
int m;
void init()
{
memset(nextval,0,sizeof(nextval));
m=strlen(a);
}
void get_next()
{
for(int i=1;i<m;i++)
{
int j=nextval[i];
while(j&&a[i]!=a[j])
j=nextval[j];
nextval[i+1]=a[i]==a[j]?j+1:0;
}
}
}T;
int ans[2000000];
int main()
{
while(scanf("%s",T.a)==1)
{
T.init();
T.get_next();
int t=0,j=T.nextval[T.m];
while(j)
{
ans[t++]=j;
j=T.nextval[j];
}
for(int i=t-1;i>=0;i--)
{
printf("%d ",ans[i]);
}
printf("%d\n",T.m);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐