您的位置:首页 > 其它

POJ 2456 Aggressive cows(二分+贪心验证)

2017-04-12 18:06 393 查看
Aggressive cows

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13562 Accepted: 6617
Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them
is as large as possible. What is the largest minimum distance?
Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output

* Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9

Sample Output
3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

tips:最近仔细对比了下刘汝佳算法竞赛和程序设计入门中二分的写法,坑点还是很多的。

本题二分+贪心验证。时间复杂度O(NLOGN)

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;

int a[110000],n,k;
bool ok(int x)
{
int p=a[1];int cnt=1;
for(int i=2;i<=n;i++)
{
if(a[i]-p>=x){
p=a[i];
if(++cnt==k)return true;
}
}
return false;
}
int main()
{
while(cin>>n>>k)
{
for(int i=1;i<=n;i++)scanf("%d",a+i);
sort(a+1,a+1+n);
int l=0;int r=a
-a[1]+1;
while(r-l>1)
{
int m=(l+r)>>1;
if(ok(m))l=m;
else r=m;
}
cout<<l<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: