您的位置:首页 > 其它

hdu 1253 胜利大逃亡

2017-04-12 15:05 375 查看
Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.



Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1

3 3 4 20

0 1 1 1

0 0 1 1

0 1 1 1

1 1 1 1

1 0 0 1

0 1 1 1

0 0 0 0

0 1 1 0

0 1 1 0

Sample Output

11

三维的搜索,第一维表示有几个n*m大小的地图。接下来的就是普通的搜索了。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
int A, B, C, T;
struct node
{
int x, y, z;
int step;
}p;
int map[51][51][51];
int vis[51][51][51];
int dr[6][3] = {{0, 0, -1},{0, 0, 1},{1, 0, },{-1, 0, 0},{0, 1, 0},{0, -1, 0}};

void bfs()
{
p.x = 0, p.y = 0, p.z = 0, p.step = 0;
queue<node>Q;
Q.push(p);
node now, next;
vis[0][0][B] = 1;
int flag = 0;
while(!Q.empty())
{
now = Q.front();
Q.pop();
for(int i = 0; i < 6; i++)
{
next.x = now.x + dr[i][0];
next.y = now.y + dr[i][1];
next.z = now.z + dr[i][2];
if(next.x >= 0&&next.x < A&&next.y >= 0&&next.y < B&&next.z >= 0&&next.z < C&&map[next.x][next.y][next.z]!=1&&vis[next.x][next.y][next.z]==0)
{
if(map[next.x][next.y][next.z]==0)
{
vis[next.x][next.y][next.z] = 1;
next.step = now.step + 1;
Q.push(next);
}
if(next.x==A - 1&&next.y==B - 1&&next.z==C - 1)
{
if(T >= now.step + 1)
{
flag = 1;
printf("%d\n",now.step + 1);
return ;
}

}
}
}
}
if(flag == 0)
printf("-1\n");
}
int main()
{

int t;
scanf("%d",&t);
while(t--)
{
memset(vis, 0, sizeof(vis));
scanf("%d%d%d%d",&A, &B, &C, &T);
for(int i = 0; i < A; i++)
{
for(int j = 0; j < B; j++)
{
for(int k = 0; k < C; k++)
{
scanf("%d",&map[i][j][k]);

}
}
}
bfs();
/*for(int i = 0; i < A; i++)
{
for(int j = 0; j < B; j++)
{
for(int k = 0; k < C; k++)
{
printf("%d ",map[i][j][k]);
}
printf("\n");
}
printf("\n");
}
for(int i = 0; i < A; i++)
{
for(int j = 0; j < B; j++)
{
for(int k = 0; k < C; k++)
{
printf("%d ",vis[i][j][k]);
}
printf("\n");
}
printf("\n");
}
printf("%d\n",vis[A-1][B-1][C-1]);*/
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: