您的位置:首页 > 其它

杭电OJ 1003 Max Sum

2017-04-12 11:27 393 查看


Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 240571    Accepted Submission(s): 56812


Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

 

#include<iostream>
#include<cstdio>
//#define LOCAL

using namespace std;

int a[100010];
int main(int argc,char ** argv)
{
#ifdef LOCAL
freopen("data.in","r",stdin);
#endif
int T,N,sum,start,temp,end,max;
cin>>T;
int count = 1;
while(T--)
{
cin>>N;
sum = 0;
start = end = temp = 1;
max = -10000;
for(int i = 1; i <= N; i++)
{
cin>>a[i];
sum += a[i];
if(sum > max)
{
max = sum;
start = temp;
end = i;
}
if(sum < 0)
{
sum = 0;
temp = i + 1;
}
}
cout<<"Case "<<count++<<":"<<endl;
cout<<max<<" "<<start<<" "<<end<<endl;
if(T!=0)
cout<<endl;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: