您的位置:首页 > 其它

ZOJ2971-Give Me the Number

2017-04-11 23:36 281 查看
Give Me the Number
Time Limit: 2 Seconds      Memory Limit: 65536 KB

Numbers in English are written down in the following way (only numbers less than 109 are considered). Number abc,def,ghi is written as "[abc] million [def] thousand [ghi]".
Here "[xyz] " means the written down number xyz .
In the written down number the part "[abc] million" is omitted if abc = 0 , "[def] thousand" is omitted if def = 0 , and "[ghi] "
is omitted if ghi = 0 . If the whole number is equal to 0 it is written down as "zero". Note that words "million" and "thousand" are singular even if the number of millions or thousands respectively is greater than one.
Numbers under one thousand are written down in the following way. The number xyz is written as "[x] hundred and [yz] ”. ( If yz = 0 it
should be only “[x] hundred”. Otherwise if y = 0 it should be only “[x] hundred and [z]”.) Here "[x] hundred and" is omitted if x = 0 . Note that "hundred" is also always singular.
Numbers under 20 are written down as "zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine", "ten", "eleven", "twelve", "thirteen", "fourteen", "fifteen",
"sixteen", "seventeen", "eighteen", and "nineteen" respectively. Numbers from 20 to 99 are written down in the following way. Number xy is written as "[x0] [y] ", and numbers divisible by ten are written as "twenty",
"thirty", "forty", "fifty", "sixty", "seventy", "eighty", and "ninety" respectively.
For example, number 987,654,312 is written down as "nine hundred and eighty seven million six hundred and fifty four thousand three hundred and twelve", number 100,000,037 as
"one hundred million thirty seven", number 1,000 as "one thousand". Note that "one" is never omitted for millions, thousands and hundreds.
Give you the written down words of a number, please give out the original number.
Input
Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 1900) which is the number of test cases. It will be followed
by T consecutive test cases.
Each test case contains only one line consisting of a sequence of English words representing a number.
Output
For each line of the English words output the corresponding integer in a single line. You can assume that the integer is smaller than 109.
Sample Input

3
one
eleven
one hundred and two


Sample Output

1
11
102

Author: CAO, Peng
Source: The 5th Zhejiang Provincial Collegiate Programming Contest

题意:用英文给出一个数字,用阿拉伯数字表示出来

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;
#define LL long long

string s1[30]={"zero","one","two","three","four","five","six","seven","eight","nine","ten","eleven","twelve",
"thirteen","fourteen","fifteen","sixteen","seventeen","eighteen","nineteen"
};
string s2[15]={"twenty","thirty","forty","fifty","sixty","seventy","eighty","ninety"};
char ch[1000];

int main()
{
map<string,int>mp;
for(int i=0;i<20;i++) mp[s1[i]]=i;
for(int i=0;i<8;i++) mp[s2[i]]=20+i*10;
int t;
scanf("%d",&t);
getchar();
while(t--)
{
gets(ch);
int len=strlen(ch);
ch[len]=' ';
len++;
string s;
int ans=0,k=0;
for(int i=0;i<len;i++)
{
if(ch[i]==' ')
{
if(s=="million")
{
ans+=k*1000000;
k=0;
}
else if(s=="thousand")
{
ans+=k*1000;
k=0;
}
else if(s=="hundred") k*=100;
else k=k+mp[s];
s.clear();
}
else s+=ch[i];
}
ans+=k;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: