您的位置:首页 > 其它

HDU 2602 Bone Collector【01背包】

2017-04-11 21:56 411 查看
Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?



Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

Sample Output

14

Code

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int N = sc.nextInt();
sc.nextLine();
while (N-- > 0) {
String[] tmp = sc.nextLine().split(" ");
int n = Integer.parseInt(tmp[0]);
int w = Integer.parseInt(tmp[1]);
int[] weight = new int
;
int[] value = new int
;
tmp = sc.nextLine().split(" ");
for (int i = 0; i < n; i++)
value[i] = Integer.parseInt(tmp[i]);
tmp = sc.nextLine().split(" ");
for (int i = 0; i < n; i++)
weight[i] = Integer.parseInt(tmp[i]);

int[][] dp = new int[n + 1][w + 1];
for (int i = 0; i < n; i++)
for (int j = 0; j <= w; j++) {
if (j < weight[i])
dp[i + 1][j] = dp[i][j];
else
dp[i + 1][j] = Math.max(dp[i][j], dp[i][j - weight[i]] + value[i]);
}
System.out.println(dp
[w]);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  oj