您的位置:首页 > 其它

poj 2230 Watchcow

2017-04-11 21:07 302 查看
Watchcow

Time Limit: 3000MS Memory Limit: 65536K

Total Submissions: 7923 Accepted: 3459 Special Judge

Description

Bessie’s been appointed the new watch-cow for the farm. Every night, it’s her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she’s done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she’s seen everything she needs to see. But since she isn’t, she wants to make sure she walks down each trail exactly twice. It’s also important that her two trips along each trail be in opposite directions, so that she doesn’t miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

Line 1: Two integers, N and M.

Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5

1 2

1 4

2 3

2 4

3 4

Sample Output

1

2

3

4

2

1

4

3

2

4

1

Hint

OUTPUT DETAILS:

Bessie starts at 1 (barn), goes to 2, then 3, etc…

题意:本森是个看牛的行家,现在他在n个地方m条路上看牛,规定巡逻要巡两次

题目中给的样例一定能过,因此输出路径,欧拉回路输出路径直接用Eluer算法

每次判断当前节点是否有桥与其连接,邻接表建图

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
#define N 10000+10
int vist[10*N],map
;
struct node
{
int to,next;
} edge[10*N];

int Euler(int s)
{
for(int i=map[s]; i!=-1; i=edge[i].next)
{
if(!vist[i])
{
vist[i]=1;
Euler(edge[i].to);
}
}
printf("%d\n",s);
}

int main()
{
int n,m;
int u,v;
int ans=0;
scanf("%d %d",&n,&m);
for(int i=0; i<=n; i++)
map[i]=-1;
for(int i=0; i<=2*m; i++) ///访问两次
vist[i]=0;
for(int i=0; i<m; i++)
{
scanf("%d %d",&u,&v);
edge[ans].to=v;
edge[ans].next=map[u];
map[u]=ans++;
edge[ans].to=u;
edge[ans].next=map[v];
map[v]=ans++;
}
Euler(1);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: