您的位置:首页 > 其它

POJ_2752_Seek the Name, Seek the Fame【kmp】

2017-04-11 17:38 405 查看
/*

Seek the Name, Seek the Fame

Time Limit: 2000MS        Memory Limit: 65536K

Total Submissions: 18796        Accepted: 9649

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative
little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab

aaaaa

Sample Output

2 4 9 18

1 2 3 4 5

大致题意:

    给出一个字符串s,求出s中存在多少子串,使得这些子串既是s的前缀,又是s的后缀。从小到大依次输出这些子串的长度。

做这道题 真真实实的 感受到NEXT数组的强大。

            a b a b c a b a b  a   b  a   b  c  a  b  a  b

len            1 2 3 4 5 6 7 8 9  10  11  12  13 14  15  16 17 18

next[i]          0 0 1 2 0 1 2 3 4  3   4  3  4   5  6  7  8  9

*/

#include <cstdio>
#include <cstring>
using namespace std;
const int MAX = 400000+10;
char s[MAX];
int next[MAX];
void get_next(int len)//得到next数组
{
int i = 0,j = -1;
next[0] =  -1;
while(i<len){
if(j==-1 || s[i]==s[j]){
++i;++j;
next[i] = j;
}
else{
j = next[j];
}
}
}
void _print(int len)//递归遍历
{
if(next[len]>0){
_print(next[len]);
printf("%d ",next[len]);
}
}
int main()
{
while(scanf("%s",s)!=EOF)
{
int i;
int len = strlen(s);
get_next(len);
_print(len);
printf("%d\n",len);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: