您的位置:首页 > 其它

HDU_1009 FatMouse' Trade 【贪心】

2017-04-11 07:19 423 查看

题目信息


FatMouse' Trade

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All
integers are not greater than 1000.

 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

 

Sample Output

13.333
31.500

解题思路:

基础的贪心算法,按照J[i]/F[i]从大到小排序,i为0~N-1,判断J[i]与M的大小,如果F[i]小于M,SUM就加上J[i],M刷新为M-J[i],否则SUM加上M*J[i]/F[i],M为0。最后将SUM保留三位小数点输出。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <set>
#include <algorithm>
#include <map>
using namespace std;
struct food
{
double j,f,p;
}F[1005];
bool cmp(food a,food b)
{
return a.p>b.p;
}
int main()
{
double m,n;
while(~scanf("%lf%lf",&m,&n))
{
double sum=0;
if(m==-1&&n==-1)
break;
for(int i=0;i<n;i++)
{
scanf("%lf%lf",&F[i].j,&F[i].f);
F[i].p=F[i].j/F[i].f;
}
sort(F,F+(int)n,cmp);
for(int i=0;i<n;i++)
{
if(m>=F[i].f)
{
m-=F[i].f;
sum+=F[i].j;
}
else
{
sum+=F[i].p*m;
break;
}
}
printf("%.3lf\n",sum);
}
return 0;
}


注意事项:

如果输入用cin会超时(Time Limit Exceeded),改为scanf就可以了
多组实例测试,以-1 -1结束
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: