您的位置:首页 > 其它

ZOJ 3956 Course Selection System(01背包)

2017-04-10 23:31 295 查看
Course Selection System
Time Limit: 1 Second      Memory Limit: 65536 KB

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and
credit Ci. If a student selects m courses x1, x2, ..., xm,
then his comfort level of the semester can be defined as follows:



Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.
Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤
10000, 1 ≤ Ci ≤ 100).
It is guaranteed that the sum of all n does not exceed 5000.
We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input

2
3
10 1
5 1
2 10
2
1 10
2 10

Sample Output

191
0

Hint

For the first case, Edward should select the first and second courses.
For the second case, Edward should select no courses.

思路:由给出的公式我们可以知道C固定时,H越大越好,因为C的总和最大50000,所

以我们可以通过01背包计算出每个C能得到的最大的H,复杂度∑C*N。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
const int maxn = 50005;
ll n, dp[maxn], h[maxn], c[maxn];

int main(void)
{
int t;
cin >> t;
while(t--)
{
memset(dp, 0, sizeof(dp));
scanf("%lld", &n);
for(int i = 1; i <= n; i++)
{
scanf("%lld%lld", &h[i], &c[i]);
for(int j = maxn-1; j >= c[i]; j--)
dp[j] = max(dp[j], dp[j-c[i]]+h[i]);
}
ll ans = 0;
for(ll i = 0; i < maxn; i++)
ans = max(ans, dp[i]*dp[i]-dp[i]*i-i*i);
printf("%lld\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  01背包 zoj