您的位置:首页 > 其它

ZOJ 3212 K-Nice(思维)

2017-04-10 21:32 399 查看
K-Nice
Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge
This is a super simple problem. The description is simple, the solution is simple. If you believe so, just read it on. Or if you don't, just pretend that you can't see this one.
We say an element is inside a matrix if it has four neighboring elements in the matrix (Those at the corner have two and on the edge have three). An element inside a matrix is called
"nice" when its value equals the sum of its four neighbors. A matrix is called "k-nice" if and only if k of the elements inside the matrix are "nice".
Now given the size of the matrix and the value of k, you are to output any one of the "k-nice" matrix of the given size. It is guaranteed that there is always a solution
to every test case.
Input
The first line of the input contains an integer T (1 <= T <= 8500) followed by T test cases. Each case contains three integers n, m, k (2
<= n, m <= 15, 0 <= k <= (n - 2) * (m - 2)) indicating the matrix size n * m and it the "nice"-degree k.
Output
For each test case, output a matrix with n lines each containing m elements separated by a space (no extra space at the end of the line). The absolute value of the elements
in the matrix should not be greater than 10000.
Sample Input

2
4 5 3
5 5 3


Sample Output

2 1 3 1 1
4 8 2 6 1
1 1 9 2 9
2 2 4 4 3
0 1 2 3
4000
0
0 4 5 6 0
0 0 0 0 0
0 0 0 0 0
0 0 0 0 0


Author: ZHUANG, Junyuan
Source: The 6th Zhejiang Provincial Collegiate Programming Contest

题意:若一个数等于其相邻四数加和,我们就称它为nice数,现要求我们构建一个n*m的矩阵,其中恰好有n个nice数。

#include<bits/stdc++.h>
using namespace std;
int a[20][20];
int main()
{
int t;
scanf("%d",&t);
int n,m,k;
while(t--)
{
scanf("%d%d%d",&n,&m,&k);
memset(a,0,sizeof(a));
int cnt=1,flag=0;
k=(m-2)*(n-2)-k;
for(int i=0;i<n-1;i++)
{
for(int j=1;j<m-1;j++)
{
if(cnt<=k)
{
a[i][j]=cnt++;
}
else flag=1;
}
if(flag)
break;
}
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
printf("%d%c",a[i][j],j<m-1?' ':'\n');
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: