您的位置:首页 > 其它

ZOJ - 3956Course Selection System(背包)

2017-04-10 12:33 281 查看
Course Selection System
Time Limit: 1 Second      Memory Limit: 65536 KB
There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and
credit Ci. If a student selects m courses x1, x2, ..., xm,
then his comfort level of the semester can be defined as follows:



Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.
Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤
10000, 1 ≤ Ci ≤ 100).
It is guaranteed that the sum of all n does not exceed 5000.
We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input

2
3
10 1
5 1
2 10
2
1 10
2 10

Sample Output

191
0

Hint

For the first case, Edward should select the first and second courses.
For the second case, Edward should select no courses.

题目大意:
给你n门课程,每门课程都有一个H值和C值,让你选出一些课程使上面的式子最大。

思路:
对于题目中的式子

 =ans的两边同除以segema(Hxi)会发现在segema(Cxi)相同的情况下,segema(Hxi)的值越大,答案也就越大。所以就是一个背包题了。dp[i]表示segema(Cxi)为i的情况下segema(H)的最大值
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long ll;
#define pii pair<ll, ll>
ll dp[50005];
pii Course[5005];
int main()
{
int n, T;
scanf("%d", &T);
while(T--)
{
ll sum = 0;
scanf("%d", &n);
for(int i = 1; i <= n; i++)
{
scanf("%I64d%I64d", &Course[i].first, &Course[i].second);
sum += Course[i].second;
}
memset(dp, 0, sizeof(dp));
for(int i = 1; i <= n; i++)
for(ll j = sum; j >= 0; j--)
if(Course[i].second <= j)
dp[j] = max(dp[j], dp[j-Course[i].second] + Course[i].first);
ll ans = 0;
for(ll i = 1; i <= sum; i++)
{
if(dp[i] == 0)
continue;
ans = max(ans, dp[i]*dp[i] - i*dp[i] - i*i);
}
cout << ans << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: