您的位置:首页 > 其它

HDU 5384 Danganronpa

2017-04-09 23:26 239 查看


Danganronpa

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Problem Description

Danganronpa is a video game franchise created and developed by Spike Chunsoft, the series' name is compounded from the Japanese words for "bullet" (dangan) and "refutation" (ronpa).

Now, Stilwell is playing this game. There are n verbal
evidences, and Stilwell has m "bullets".
Stilwell will use these bullets to shoot every verbal evidence.

Verbal evidences will be described as some strings Ai,
and bullets are some strings Bj.
The damage to verbal evidence Ai from
the bullet Bj is f(Ai,Bj).

f(A,B)=∑i=1|A|−|B|+1[ A[i...i+|B|−1]=B ]
In other words, f(A,B) is
equal to the times that string B appears
as a substring in string A.

For example: f(ababa,ab)=2, f(ccccc,cc)=4

Stilwell wants to calculate the total damage of each verbal evidence Ai after
shooting all m bullets Bj,
in other words is ∑mj=1f(Ai,Bj).

 

Input

The first line of the input contains a single number T,
the number of test cases.

For each test case, the first line contains two integers n, m.

Next n lines,
each line contains a string Ai,
describing a verbal evidence.

Next m lines,
each line contains a string Bj,
describing a bullet.

T≤10

For each test case, n,m≤105, 1≤|Ai|,|Bj|≤104, ∑|Ai|≤105, ∑|Bj|≤105

For all test case, ∑|Ai|≤6∗105, ∑|Bj|≤6∗105, Ai and Bj consist
of only lowercase English letters

 

Output

For each test case, output n lines,
each line contains a integer describing the total damage of Ai from
all m bullets, ∑mj=1f(Ai,Bj).

 

Sample Input

1
5 6
orz
sto
kirigiri
danganronpa
ooooo
o
kyouko
dangan
ronpa
ooooo
ooooo

 

Sample Output

1
1
0
3
7

 
AC自动机,不过这一题字典树也能过,数据比较水吧。
求所有B串在某一A串中出现的次数,我们可以把所有B串构建字典树,遍历A串的所有后缀,判断是多少个B串的母串。
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
#define maxn 100005
using namespace std;
int ch[maxn * 10][26];
int sz;
int val[maxn * 10];
void init()
{
sz = 1;
memset(ch, 0, sizeof(ch));
memset(val, 0, sizeof(val));
}
void insert_s(char *s)
{
int u = 0, i, c, len = strlen(s);
for (i = 0; i < len; i++)
{
c = s[i] - 'a';
if (!ch[u][c])
{
ch[u][c] = sz++;
}
u = ch[u][c];
}
//必须放在这,因为字典树里的字符串是子串,必须达到最后一个字母才算匹配成功
val[u]++;
}
long long query(string s)
{
int u = 0, i, c, l = s.length();
long long ans = 0;
for (i = 0; i < l; i++)
{
c = s[i] - 'a';
if (!ch[u][c])
{
return ans;
}
u = ch[u][c];
ans += val[u];
}
return ans;
}
int main()
{
ios::sync_with_stdio(false);
int t;
cin>>t;
//ios::sync_with_stdio(false);  wrong了好久,G++不能把这句话放在这里,不然莫名WA
while (t--)
{
init();
int n, m;
cin>>n>>m;
string str[maxn];
for (int i = 0; i < n; i++)
{
cin >> str[i];
}
for (int i = 0; i < m; i++)
{
char tmp[maxn];
cin>>tmp;
insert_s(tmp);
}
for (int i = 0; i < n; i++)
{
long long ansx = 0;
for (int j = 0; j < str[i].length(); j++)
{
//cout<<ans<<endl;
ansx += query(str[i].substr(j));
}
cout<<ansx<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: