您的位置:首页 > 产品设计 > UI/UE

POJ1679 The Unique MST(判断最小生成树是否唯一)

2017-04-09 21:53 555 查看
The Unique MST

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 29791 Accepted: 10664
Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 

1. V' = V. 

2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a
triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output
3
Not Unique!

Source

POJ Monthly--2004.06.27 srbga@POJ
思路:题目要求的是判断最小生成树是否唯一,则要判重就要找到与第n-1条边相等的边,把n-1之前和n-1之后的边进行比较,如果存在相等的顶点,则一定能够替换,即最小生成树不唯一。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int par[105],rank[105];
struct node{
int u,v,w;
}edge[100005];

bool cmp(node A, node B){
return A.w < B.w;
}

int find(int x){
if(x == par[x])
return x;
return par[x] = find(par[x]);
}

int UnoinSet(int u, int v){
int x = find(u);
int y = find(v);
if(x != y){
if(rank[x] > rank[y])
par[y] = x;
else{
par[x] = y;
if(rank[x] == rank[y])
rank[y] ++;
}
return 1;
}
return 0;
}

int main(){
int t,n,m,cnt,ans;
scanf("%d",&t);
while(t --){
cnt = ans = 0;
scanf("%d%d",&n,&m);
for(int i = 1; i <= n; i ++){
par[i] = i;
rank[i] = 0;
}

for(int i = 0; i < m; i ++){
scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
}
sort(edge,edge+m,cmp);

for(int i = 0; i < m; i ++){
int index = UnoinSet(edge[i].u,edge[i].v);
if(index){
ans += edge[i].w;  cnt ++;
}
if(cnt == n-1)
break;
}

int flag = 0;
if(edge[n-2].w == edge[n-1].w){//判断第n-1条边之前与其相等的和之和与其相等的
int index=0;
for(int i = 0; i < n-2; i ++){
if(edge[i].w == edge[n-2].w){
index = i;
break;
}
}
for(; index <= n-2; index ++){//如果存在边的顶点相等,则一定能够替换
for(int j = n-1; edge[j].w == edge[n-2].w && j < m; j ++){
if(edge[index].u == edge[j].u || edge[index].v == edge[j].v || edge[index].u == edge[j].v || edge[index].v == edge[j].u){
flag = 1;
break;
}
}
if(flag)
break;
}
}

if(flag)
printf("Not Unique!\n");
else
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: