您的位置:首页 > 其它

poj2262 简单素数判定

2017-04-08 16:48 337 查看
Goldbach's Conjecture

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45296 Accepted: 17255
Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 

written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 

20 = 3 + 17 = 7 + 13. 

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 

Each test case consists of one even integer n with 6 <= n < 1000000. 

Input will be terminated by a value of 0 for n.
Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair
where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."
Sample Input
8
20
42
0

Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37


题意:输入一个数,将其写成俩个素数相加的形式。

很简单的一道题,只要将第一次出现的符合条件的情况输出即可。

代码:

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
bool isodd(int x)
{
int y=sqrt(x+0.5);
for(int i=2;i<=y;i++)
{
if(x%i==0)
{
return false;
}
}
return true;
}
int main()
{
int n;
while(scanf("%d",&n)&&n!=0)
{
for(int i=3;i<=n-3;i++)
{
if(isodd(i)&&isodd(n-i))
{
printf("%d = %d + %d\n",n,i,n-i);
break;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm poj 数据