您的位置:首页 > 其它

poj 1284 Primitive Roots

2017-04-08 10:28 387 查看
Primitive Roots

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4267 Accepted: 2501
Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (xi mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive
root modulo 7. 

Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.
Output

For each p, print a single number that gives the number of primitive roots in a single line.
Sample Input
23
31
79

Sample Output
10
8
24

Source

贾怡@pku
提示

题目:

给出一个奇素数p(就是不包含2的素数),求出0到p-1有几个原根。

原根的定义:x的1到p-1次方对p取余所得的值的集合,恰好等于1到p-1的集合。

思路:

已知定理我们可知道p的原根个数为φ(p-1)。这里的φ(x)表示的是欧拉函数,求的是小于x的数中与x互质的数的数目。

示例程序

#include <cstdio>
using namespace std;
int f(int n)
{
int i,ans;
ans=n;
for(i=2;n>=i*i;i++)
{
if(n%i==0)
{
ans=ans-ans/i;
do
{
n=n/i;
}while(n%i==0);
}
}
if(n!=1)
{
ans=ans-ans/n;
}
return ans;
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
printf("%d\n",f(n-1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: