您的位置:首页 > 编程语言 > Java开发

sdut_java_3-1 Point类的构造函数

2017-04-07 20:52 330 查看


3-1 Point类的构造函数

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

通过本题目的练习可以掌握类的构造函数的定义;
设计一个点类Point,私有数据成员有x、y;公有成员函数有:无参数的构造函数Point(),带参数的构造函数Point(int,int);ShowPoint()输出点对象的信息
在主函数main()中调用相应成员函数,从键盘接收时间对象的x和y的值,并向显示器输出相应的值。


Input

 
输入2个整数,用一个空格间隔


Output

 
要求先输出默认的点值,再输出用户构造的点的值
点的格式为:一对圆括号内 x,y的值,中间用“,”间隔;


Example Input

10 11



Example Output

(0,0)
(10,11)
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner in = new Scanner (System.in);
while( in.hasNext() ){
Point p = new Point( in.nextInt(), in.nextInt());
Point p1 = new Point();
p1.show();
p.show();
}
in.close();
}
}

class Point{
private int x, y;

Point (){
x = 0;
y = 0;
}

public Point ( int x, int y ){
this.x = x;
this.y = y;
}

public void  show(){
System.out.println("("+x+","+y+")");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: