您的位置:首页 > 其它

POJ2488 【骑士游历】( dfs + 回溯 )

2017-04-07 20:17 309 查看
Description


Background 

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

要去输出字典序最小

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int N = 33;
struct P
{
int x,y;
P(int x,int y):x(x),y(y){}
P(){}
}b[N*N];
char a

;
int vis

,n,m,flag;
int dx[]={-1,1,-2,2,-2,2,-1,1};
int dy[]={-2,-2,-1,-1,1,1,2,2};
bool ok(int x,int y)
{
if(x<0||y<0||x>=n||y>=m) return true;
return false;
}
void dfs(int x,int y,int cnt)
{
int i,j,next_x,next_y;
if(flag) return;
if(cnt==n*m) {
flag=1;
for(i=1;i<=cnt;i++) printf("%c%d",b[i].y+'A',b[i].x+1);
printf("\n");
return ;
}
for(i=0;i<8;i++) {
next_x = x + dx[i];
next_y = y + dy[i];
if(ok(next_x,next_y)) continue;
if(vis[next_x][next_y]) continue;
vis[next_x][next_y]=1;
b[cnt+1]=P(next_x,next_y);
dfs(next_x,next_y,cnt+1);
if(flag) return;
vis[next_x][next_y]=0;
}
return ;
}
int main()
{
int i,j,T;
scanf("%d",&T);
for(int _=1;_<=T;_++) {
if(_!=1) printf("\n");
scanf("%d%d",&n,&m);
memset(vis,0,sizeof(vis));
flag=0;
printf("Scenario #%d:\n",_);
for(i=0;i<n;i++) {
for(j=0;j<m;j++) {
vis[i][j]=1;
b[1]=P(i,j);
dfs(i,j,1);
vis[i][j]=0;
if(flag) break;
}
if(flag) break;
}
if(!flag) printf("impossible\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: