您的位置:首页 > 其它

POJ 1979 Red and Black (dfs)

2017-04-07 17:07 295 查看
Red and Black

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 34821 Accepted: 18827
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13


还是简单的搜索……

#include <cstdio>
#include <iostream>
#include <string>
#include <queue>
#include <algorithm>

using namespace std;

int dir[4][2] = { -1, 0, 0, -1, 1, 0, 0, 1 };

char tile[25][25];
bool visit[25][25];

int w, h, cnt;

bool check(int x, int y)
{
if (!visit[x][y] && tile[x][y] == '.' && x >= 1 && x <= h && y >= 1 && y <= w)
return true;
else return false;
}

void dfs(int x, int y)
{
if (tile[x][y] == '.')
{
cnt++;
visit[x][y] = true;
}
for (int i = 0; i < 4; i++)
{
int nextX = x, nextY = y;
nextX += dir[i][0];
nextY += dir[i][1];
if (check(nextX, nextY))
dfs(nextX, nextY);
}
}

int main()
{
int stX, stY;
while (cin >> w >> h && w && h)
{
for (int i = 1; i <= h; i++)
for (int j = 1; j <= w; j++)
{
cin >> tile[i][j];
if (tile[i][j] == '@')
{
stX = i;
stY = j;
tile[i][j] = '.';
}
}
memset(visit, false, 625);
cnt = 0;
dfs(stX, stY);
cout << cnt << endl;
}

return 0;
}


“Farewell good hunter, may you find your worth in the waking world.”
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM