您的位置:首页 > 其它

E - Largest Rectangle in a Histogram ----单调栈

2017-04-06 21:46 211 查看


E - Largest Rectangle in a Histogram

 POJ
- 2559 

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists
of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 



Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned
at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn,
where0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0


Sample Output
8
4000


Hint
Huge input, scanf is recommended.

题目链接:https://cn.vjudge.net/contest/157463#problem/E

题目的意思是让你找一个最大矩形面积。

思路很简单,我们对每一个i,遍历枚举他最左边到哪,最右边到哪,然后乘起来取最大值即可。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#define LL long long
using namespace std;
int height[100010];
int L[100010];
int R[100010];
int S[100010];
int main(){
int n;
while(~scanf("%d",&n)){
if(n==0)
break;
for(int i=0;i<n;i++){
scanf("%d",&height[i]);
}
LL ans=0;
int t=0;
for(int i=0;i<n;i++){
while(t>0&&height[S[t-1]]>=height[i])
t--;
if(t==0)
L[i]=0;
else
L[i]=(S[t-1]+1);
S[t++]=i;
}
t=0;
for(int i=n-1;i>=0;i--){
while(t>0&&height[S[t-1]]>=height[i])
t--;
if(t==0)
R[i]=n;
else
R[i]=S[t-1];
S[t++]=i;
}
for(int i=0;i<n;i++){
ans=max(ans,(LL)height[i]*(R[i]-L[i]));
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: