您的位置:首页 > 其它

CSU 1336 Interesting Calculator(spfa)

2017-04-05 20:38 162 查看

Interesting Calculator

Description

There is an interesting calculator. It has 3 rows of buttons.

Row 1: button 0, 1, 2, 3, …, 9. Pressing each button appends that digit to the end of the display.

Row 2: button +0, +1, +2, +3, …, +9. Pressing each button adds that digit to the display.

Row 3: button *0, *1, *2, *3, …, *9. Pressing each button multiplies that digit to the display.

Note that it never displays leading zeros, so if the current display is 0, pressing 5 makes it 5 instead of 05. If the current display is 12, you can press button 3, +5, *2 to get 256. Similarly, to change the display from 0 to 1, you can press 1 or +1 (but not both!).

Each button has a positive cost, your task is to change the display from x to y with minimum cost. If there are multiple ways to do so, the number of presses should be minimized.

Input

There will be at most 30 test cases. The first line of each test case contains two integers x and y(0<=x<=y<=105). Each of the 3 lines contains 10 positive integers (not greater than 105), i.e. the costs of each button.

Output

For each test case, print the minimal cost and the number of presses.

Sample Input

12 256

1 1 1 1 1 1 1 1 1 1

1 1 1 1 1 1 1 1 1 1

1 1 1 1 1 1 1 1 1 1

12 256

100 100 100 1 100 100 100 100 100 100

100 100 100 100 100 1 100 100 100 100

100 100 10 100 100 100 100 100 100 100

Sample Output

Case 1: 2 2

Case 2: 12 3

Source

湖南省第九届大学生计算机程序设计竞赛

思路:变形的spfa,关键还是在松弛条件处,对于每一次的松弛都有30种情况需要判断……..具体详见代码

代码:

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;

#define mem(a,b) memset(a,b,sizeof(a))
#define maxn 100000+10
const int inf=0x3f3f3f3f;
int d[maxn],inq[maxn],cost[5][15],step[maxn];

void spfa(int st,int ed)
{
mem(d,inf);
mem(step,inf);
mem(inq,0);
d[st]=step[st]=0,inq[st]=1;
queue<int>q;
q.push(st);
while(!q.empty())
{
st=q.front();
q.pop();
inq[st]=0;
for(int i=0; i<3; ++i)
for(int j=0; j<10; ++j)
{
int x;
if(i==0)
x=st*10+j;
else if(i==1)
x=st+j;
else if(i==2)
x=st*j;
if(x>ed)
continue;
if(d[x]>d[st]+cost[i][j])
{
d[x]=d[st]+cost[i][j];
step[x]=step[st]+1;
if(!inq[x])
{
inq[x]=1;
q.push(x);
}
}
else if(d[x]==d[st]+cost[i][j]&&step[x]>step[st]+1)
{
step[x]=step[st]+1;
if(!inq[x])
{
inq[x]=1;
q.push(x);
}
}
}
}
printf("%d %d\n",d[ed],step[ed]);
}

int main()
{
int st,ed,T=1;
while(~scanf("%d%d",&st,&ed))
{
for(int i=0; i<3; ++i)
for(int j=0; j<10; ++j)
scanf("%d",&cost[i][j]);
printf("Case %d: ",T++);
spfa(st,ed);
}
return 0;
}


总结:刚开始还以为是DP呢,结果想了半天也没想出来DP怎样写。又看大佬用spfa把它给A了,顿时觉得我的最短路真水。。。(思维真是太局限了)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: