您的位置:首页 > 其它

ZOJ - 3166 Lazy Tourist

2017-04-05 20:08 162 查看
ZOJ - 3166 Lazy Tourist 

Fat Murphy is really a lazy guy. When he goes out for sightseeing, only he cared about is to get back to the hotel which he stayed in as soon as possible. Taday is the Valentine's day, Fat Murphy's girl friend plans to make a tour of Hangzhou with him. Poor
Murphy has to agree with that, or his girl friend will be really angry. As lazy as he was, he begins to collect information about Hangzhou for his own purpose. There are N sceneries in Hangzhou, and some of them are connected by a one way road. Besides, some
of the sceneries have a hotel in it. Fat Murphy wants to choose a hotel to check in, when he goes out for sightseeing, he can get back to this hotel in a minimal time.

Input

First line: two integers N, C, indicates the number of the sceneries and the number of the hotels. 1 <= N <= 100, 0 <= C <= N 

Second line: C distinct integers represent the index of the scenery which has a hotel. 

Third line: an integer M, indicates the number of the paths, 0 <= M <= N*(N-1) 

The following M lines: each line contains threes integers: a, b, d, represents there is a road from a to b, and the time needed to pass this road is d. 1 <= d <= 1000 

Process to the end of file.

Output

For each case, output a single number represents the index of the hotel that Fat Murphy chooses. 

If there is more than one optimal choice, just output the smallest one. If there is no choice, output "I will nerver go to that city!"

Sample Input

5 2
1 3
6
1 2 1
2 5 5
5 1 2
3 5 3
4 3 1
5 4 1
5 2
1 3
4
1 2 1
2 3 2
3 4 3
4 5 4


Sample Output

3
I will nerver go to that city!


【分析】有m个城市,c个旅馆,n条单向路。
求从旅馆出发在回到旅馆的最短路径。

将所有的路径都算出来,然后找最小的。

#include <bits/stdc++.h>

using namespace std;
#define cl(a,b) memset(a,b,sizeof a);
const int INF = 0x3f3f3f3f;
const int maxn = 110;
int dis[maxn][maxn],a[maxn];
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m)){
cl(a,0);
for(int i=0;i<m;i++){
scanf("%d",a+i);
}
int k;
scanf("%d",&k);
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
dis[i][j] = INF;
}
}
while(k--){
int u,v,d;
scanf("%d%d%d",&u,&v,&d);
dis[u][v] = d;
}
for(int k=1;k<=n;k++){
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
dis[i][j] = min(dis[i][j],dis[i][k]+dis[k][j]);
}
}
}
int ans = 0,mi = INF;
for(int i=0;i<m;i++){
if(dis[a[i]][a[i]] < mi){
ans = a[i];
mi = dis[a[i]][a[i]];
}
}
if(ans){
printf("%d\n",ans);
}
else
printf("I will nerver go to that city!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: