您的位置:首页 > 其它

HDU1241 Oil Deposits 【DFS】

2017-04-05 19:37 441 查看
Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following
this are m lines of n characters each (not counting the end-of-line character
4000
s). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

Sample Output

0
1
2
2

 

题意:给定大小为m*n的矩形代表油田,@为有油的地方,每块有油的地方都可以和相邻的有油的地方构成油田,问共有多少块油田。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;

const int maxn=105;
char map[maxn][maxn];
bool visit[maxn][maxn];
int dx[8]= {0,1,0,-1,1,1,-1,-1};
int dy[8]= {1,0,-1,0,1,-1,1,-1};
int n, m, sum;
void dfs(int x,int y)
{
map[x][y]='.';
for(int i=0; i<8; i++)
{
int xx=x+dx[i];
int yy=y+dy[i];
if(map[xx][yy]!='@'||xx<0||yy<0||xx>=n||yy>=m)
continue;
dfs(xx,yy);
}
}
int main()
{
while(~scanf("%d%d",&n,&m) && (n+m))
{
sum=0;for(int i=0; i<n; ++i)
scanf("%s",map[i]);
for(int i=0; i<n; ++i)
for(int j=0; j<m; ++j)
if(map[i][j]=='@')
{
dfs(i,j);
sum++;
}
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: