您的位置:首页 > 其它

HDU1312 Red and Black 【DFS模板】

2017-04-05 18:12 375 查看
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

InputThe input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

OutputFor each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output
45
59
6
13


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;

/*
const int maxn=100;
bool vst[maxn][maxn]; // 访问标记
int map[maxn][maxn]; // 坐标范围
int dir[4][2]= {0,1,0,-1,1,0,-1,0}; // 方向向量,(x,y)周围的四个方向
bool CheckEdge(int x,int y) // 边界条件和约束条件的判断
{
if(!vst[x][y] && ...) // 满足条件
return 1;
else // 与约束条件冲突
return 0;
}
void dfs(int x,int y)
{
vst[x][y]=1; // 标记该节点被访问过
if(map[x][y]==G) // 出现目标态G
{
...... // 做相应处理
r
bc3e
eturn;
}
for(int i=0; i<4; i++)
ACM Book
BFS 52
{
if(CheckEdge(x+dir[i][0],y+dir[i][1])) // 按照规则生成下一个节点
dfs(x+dir[i][0],y+dir[i][1]);
}
return; // 没有下层搜索节点,回溯
}
int main()
{
......
return 0;
}
*/

const int maxn=20;
char map[maxn][maxn];
bool visit[maxn][maxn];
int dx[4]= {0,1,0,-1};
int dy[4]= {1,0,-1,0};
int n, m, sum;
void dfs(int x, int y)
{
int xx, yy;
for(int i=0; i<4; ++i)
{
xx = x + dx[i];
yy = y + dy[i];
if(xx<0 || yy<0 || xx>=n || yy>=m) continue;//越界
if(map[xx][yy] == '.')
{
sum++;
map[xx][yy] = '#'; //表示已访问过,也可以用visit数组标记
dfs(xx, yy);
}
}
}
int main()
{
int fi,fj;
while(~scanf("%d%d",&m,&n) && (n+m))
{
sum=1;
//for(int i=0; i<maxn; ++i)
// for(int j=0; j<maxn; ++j)
// map[i][j]=0;
//此处不需初始化,多此一举
for(int i=0; i<n; ++i)
{
for(int j=0; j<m; ++j)
{
cin>>map[i][j];
if(map[i][j]=='@')
{
fi=i,fj=j;
map[fi][fj]='#';
}
}
getchar();
}
/*或
for(int i=0;i<n;i++)
scanf("%s",&map[i]);
for(int i=0; i<n; ++i)
for(int j=0; j<m; ++j)
if(map[i][j]=='@')
{
map[fi][fj]='#';
dfs(i,j);
}
*/
dfs(fi,fj);
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: