您的位置:首页 > 其它

NSWOJ ~ 1104 ~ BinaryStringMatching(strstr函数)

2017-04-05 15:39 253 查看
题意:先给你一个数代表有几组测试数据,然后每组测试数据给你两个字符串A,B,求A在B中出现的次数;


1104 - BinaryStringMatching

时间限制:3秒 内存限制:128兆

题目描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the
pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer
than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011


样例输出
3
0
3


提示

来源
NYOJ

思路:用到一个strstr(string a,string b)函数,函数意思为找到a字符串在b中第一次出现的位置然后返回;用这个函数就很好写了找到第一次出现的位置然后这个坐标加1,出现次数加一,在找,直到找不到;

#include<stdio.h>
#include<string.h>
int strstrcount( char *str1, char *str2 )
{
char *str = str1;
int c = 0;

while( (str = strstr( str, str2 )) != NULL )
{
c++;
str++;
}
return c;
}
main()
{
char str[10001];
int n,i;
scanf("%d",&n);
while(n--)
{
int count=0;
char a[10001];
scanf("%s",str);
scanf("%s",a);
count=strstrcount(a,str);
printf("%d\n",count);
}
}


d56b
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: