您的位置:首页 > 其它

简单枚举类型——植物与颜色

2017-04-05 10:22 246 查看
Home

Contests
Problems
Ranklist
Status
15110506055
Logout

简单枚举类型——植物与颜色

Time Limit: 1000MS
Memory Limit: 65536KB
Submit

Statistic

Problem Description

 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 

Input

 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。

Output

 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 

Example Input

blue
yellow
purple


Example Output

Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.


Hint

 请用枚举类型实现。

Author

 lxh 

import java.util.*;
import java.math.*;
class S
{
public String col;
public String flo;
S(String s1,String s2)
{
this.flo = s1;
this.col = s2;
}
}
public class Main {

public static void main(String[] args) {
Scanner input = new Scanner(System.in);
S s[] = {new S("Rose","red"),new S("Poppies","orange"),new S("Sunflower","yellow"),new S("Grass","green"),
new S("Bluebells","blue"),new S("Violets","violet")};
String ss;
while(input.hasNext())
{
ss = input.nextLine();
int flag = 0;
for(int i=0;i<6;i++)
{
if(s[i].col.equals(ss))
{
System.out.println(s[i].flo+" are "+ss+".");
flag = 1;
break;
}

}
if(flag==0)
{
System.out.println("I don't know about the color "+ss+".");
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: