您的位置:首页 > 其它

POJ_3723_Conscription【最小生成树】

2017-04-04 20:55 357 查看
Conscription

Time Limit: 1000MS        Memory Limit: 65536K

Total Submissions: 13020        Accepted: 4565

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between
girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys,
your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.

The first line of each test case contains three integers, N, M and R.

Then R lines followed, each contains three integers xi, yi and di.

There is a blank line before each test case.

1 ≤ N, M ≤ 10000

0 ≤ R ≤ 50,000

0 ≤ xi < N

0 ≤ yi < M

0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8

4 3 6831

1 3 4583

0 0 6592

0 1 3063

3 3 4975

1 3 2049

4 2 2104

2 2 781

5 5 10

2 4 9820

3 2 6236

3 1 8864

2 4 8326

2 0 5156

2 0 1463

4 1 2439

0 4 4373

3 4 8889

2 4 3133

Sample Output

71071

54223

题意:需要征募女兵N人,男兵M人,每征一个人需要10000元,但是如果在已经征募到的人中有一些关系亲密的人,那么可以少花一点钱.给出若干男女间的亲密度关系,

征募的费用是10000-已被征募的人中和自己亲密度的最大值,要求征募总费用最小

题解:男女间的关系看成一条边,这个问题就可以转化成求解无向图中最大权森林的问题。

可以通过把所以权取反之后用最小生成树的算法求解。 (因为每个人值需要取亲密度最大的边,因此一定不会构成环)

*/

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int Max = 50000 + 5;
struct Node
{
int u;
int v;
int w;
}edge[Max];
int s[Max];
void init()
{
int i;
for(i=0;i<=Max;i++)//初始化
{
s[i] = i;
}
}
int cmp(const void *a,const void *b)
{
Node *c = (Node *) a;
Node *d = (Node *) b;
if(c->w > d->w)
{
return 1;
}
else
{
return -1;
}
}
int find(int x)
{
if(x==s[x])
{
return x;
}
else
{
return s[x] = find(s[x]);
}
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int i,j,n,m,r;
scanf("%d%d%d",&n,&m,&r);

init();

for(i=0;i<r;i++)
{
scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
edge[i].v += n; //把男生的编号设置成 n+i;
edge[i].w = -edge[i].w;//权值设置成 它的相反数
}
qsort(edge,r,sizeof(edge[0]),cmp);//按照weight从小到大排序
int ans = 0;
for(i=0;i<r;i++)
{
int _x = find(edge[i].u);
int _y = find(edge[i].v);
//printf("%d %d\n",edge[i].u,edge[i].v);
//printf("%d %d\n",_x,_y);
if(_x!=_y)
{
s[_x] = _y;
ans += edge[i].w;
}
}
printf("%d\n",(n+m)*10000+ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: