您的位置:首页 > 其它

HDU1312-Red and Black-DFS

2017-04-04 17:57 459 查看

Red and Black

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19690 Accepted Submission(s): 11965


[align=left]Problem Description[/align]
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

[align=left]Sample Input[/align]



[align=left]Sample Output[/align]

45

59

6

13

好久之前的,忘了写了。

#include<bits/stdc++.h>
using namespace std;
int direct [4][2]={-1,0,1,0,0,1,0,-1};                                    //方向
char str[25][25];
bool flag[25][25];
int w,h,ans;
void DFS(int x,int y){
for(int i=0;i<4;i++){
int p=x+direct[i][0];
int q=y+direct[i][1];
if(p>=0&&q>=0&&p<h&&q<w&&flag[p][q]==0&&str[p][q]=='.'){         //判断,至今仍不明白方向为-1的时候怎么还是>=0,
ans++;
flag[p][q]=1;
DFS(p,q);                                                    //递归
}
}
}
int main(){
int i,j,k;
int Dx,Dy;
while(~scanf("%d%d",&w,&h)){
if(w==0&&h==0)break;
memset(flag,0,sizeof(flag));                                    //这个函数通常为新申请的内存做初始化工作
getchar();
for(i=0;i<h;i++){
for(j=0;j<w;j++){
scanf("%c",&str[i][j]);
if(str[i][j]=='@'){
Dx=i;
Dy=j;
}
} getchar();
}
ans=1;
flag[Dx][Dy]=1;
DFS(Dx,Dy);
printf("%d\n",ans);
}
return 0;
}


写下来,等忘的时候再回来看。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: