您的位置:首页 > 编程语言 > Java开发

HDU 5112 A Curious Matt (Java comparator + 快速IO + 控制浮点精度)

2017-04-04 17:05 597 查看




A Curious Matt

                                                                   Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000
K (Java/Others)

                                                                                         Total Submission(s): 2395    Accepted
Submission(s): 1355


Problem Description

There is a curious man called Matt.

One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please
help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.

Input

The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers ti and xi (0 ≤ ti, xi ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time.
It’s guaranteed that all ti would be distinct.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.

Sample Input

2
3
2 2
1 1
3 4
3
0 3
1 5
2 0

 

Sample Output

Case #1: 2.00
Case #2: 5.00

HintIn the first sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

 

Source

2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5112

import java.util.*;
import java.text.*;
import java.io.*;

public class Main{

public static int T;
public static int n;

static class myScanner {
BufferedReader br;
StringTokenizer st;

public myScanner(InputStream in) {
br = new BufferedReader(new InputStreamReader(in));
st = new StringTokenizer("");
}

public String nextLine() {
try {
return br.readLine();
} catch(IOException e) {
return null;
}
}

public boolean hasNext() {
while (!st.hasMoreTokens()) {
String s = nextLine();
if (s == null) {
return false;
}
st = new StringTokenizer(s);
}
return true;
}

public String next() {
hasNext();
return st.nextToken();
}

public int nextInt() {
return Integer.parseInt(next());
}

public double nextDouble() {
return Double.parseDouble(next());
}
}

static class Data {
double t, x;
}

public static void main(String[] agrs) {
myScanner in = new myScanner(System.in);
PrintWriter pw = new PrintWriter(System.out);
T = in.nextInt();
for (int ca = 1; ca <= T; ca ++) {
System.out.print("Case #" + ca + ": ");
n = in.nextInt();
Data[] d = new Data
;
for (int i = 0; i < n; i ++) {
d[i] = new Data();
d[i].t = in.nextDouble();
d[i].x = in.nextDouble();
}

Comparator <Data> cmp = new Comparator<Data>() {
public int compare(Data a, Data b) {
if (a.t > b.t) {
return 1;
} else if (a.t < b.t) {
return -1;
} else {
if (a.x > b.x) {
return 1;
} else if (a.x < b.x) {
return -1;
} else {
return 0;
}
}
}
};
Arrays.sort(d, cmp);
double ma = 0;
for (int i = 1; i < n; i ++) {
ma = Math.max(ma, Math.abs(d[i].x - d[i - 1].x) / (d[i].t - d[i - 1].t));
}
pw.println(new DecimalFormat("0.00").format(ma));
pw.flush();
}
pw.close();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: