您的位置:首页 > 其它

SDUT 1959 简单枚举类型——植物与颜色

2017-04-04 16:34 225 查看


简单枚举类型——植物与颜色

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 


Input

 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。


Output

 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 


Example Input

blue
yellow
purple



Example Output

Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.

import java.text.DecimalFormat;
import java.util.Scanner;

enum color {
red, orange, yellow, green, blue, violet
}

public class Main {

public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while (sc.hasNext()) {
String s = sc.next();
if(s.equals(color.blue.name())==true)
System.out.println("Bluebells are blue.");
else if(s.equals(color.yellow.name())==true)
System.out.println("Sunflower are yellow.");
else if(s.equals(color.red.name())==true)
System.out.println("Rose are red.");
else if(s.equals(color.orange.name())==true)
System.out.println("Poppies are orange.");
else if(s.equals(color.violet.name())==true)
System.out.println("Violets are violet.");
else if(s.equals(color.green.name())==true)
System.out.println("Grass are green.");
else
System.out.println("I don't know about the color "+s+".");
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: