您的位置:首页 > 其它

HDOJ 2616 Kill the monster(DFS+BFS)

2017-04-03 00:30 483 查看

Kill the monster

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1510    Accepted Submission(s): 1030
[/b]

Problem Description

There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it.

Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to
monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.

 

Input

The input contains multiple test cases.

Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.

Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).

 

Output

For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.

 

Sample Input

3 100
10 20
45 89
5 40

3 100
10 20
45 90
5 40

3 100
10 20
45 84
5 40

 

Sample Output

3
2
-1

法一:DFS

#include <bits/stdc++.h>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define f(i,a,b) for(int i=(a);i<(b);i++)
#define maxn 11
#define mod 10007
#define ll long long
#define rush() int t;scanf("%d",&t);while(t--)
int n,m,ans,a[maxn],b[maxn],vis[maxn];
void dfs(int ph,int num)
{
if(ph<=0)
{
if(num<ans)
{
ans=num;
return;
}
}
if(num>=n) return;
f(i,0,n)
{
if(!vis[i])
{
vis[i]=1;
if(ph<=b[i])
dfs(ph-a[i]*2,num+1);
else
dfs(ph-a[i],num+1);
vis[i]=0;
}
}
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
ans=maxn;
f(i,0,n)
{
scanf("%d%d",&a[i],&b[i]);
}
mst(vis,0);
dfs(m,0);
if(ans==maxn)
printf("-1\n");
else printf("%d\n",ans);
}
return 0;
}


法二:BFS

#include <bits/stdc++.h>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define f(i,a,b) for(int i=(a);i<(b);i++)
#define maxn 11
#define mod 10007
#define ll long long
#define rush() int t;scanf("%d",&t);while(t--)
struct node
{
int vis[maxn],ans,hp;
};
int n,m,a[maxn][2];
int bfs()
{
node now,nex;
mst(now.vis,0);
now.ans=0;
now.hp=m;
queue<node> q;
q.push(now);
while(q.size())
{
now=q.front();
q.pop();
f(i,0,n)
{
if(now.vis[i])
continue;
nex=now;
nex.vis[i]=1;
nex.ans++;
if(nex.hp<=a[i][1])
nex.hp-=a[i][0]*2;
else nex.hp-=a[i][0];
if(nex.hp<=0) return nex.ans;
q.push(nex);
}
}
return -1;
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
f(i,0,n)
{
scanf("%d%d",&a[i][0],&a[i][1]);
}
printf("%d\n",bfs());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: