您的位置:首页 > 其它

hdu 1003 Max Sum (dp)

2017-04-02 15:11 351 查看

Max Sum

[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6

分析:动态规划求解:dp[i]表示i之前的某个位置到i的和(也包括i到i).

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=100000+10;
int dp[maxn];
int a[maxn];
int main(){
int T;
scanf("%d",&T);
int cnt=0;
while(T--){
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);

dp[1]=a[1];
for(int i=2;i<=n;i++){
if(dp[i-1]<0)dp[i]=a[i];
else dp[i]=dp[i-1]+a[i];
}
int max=dp[1];
int end=1;
for(int i=2;i<=n;i++){
if(max<dp[i]){
max=dp[i];
end=i;
}
}
int start=end;
int sum=0;
for(int i=end;i>=1;i--){
sum+=a[i];
if(sum==max){
start=i;
}
}

printf("Case %d:\n",++cnt);
printf("%d %d %d\n",max,start,end);
if(T)printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: