您的位置:首页 > 其它

基础练习 报时助手

2017-04-01 18:35 309 查看
问题描述

  给定当前的时间,请用英文的读法将它读出来。

  时间用时h和分m表示,在英文的读法中,读一个时间的方法是:

  如果m为0,则将时读出来,然后加上“o’clock”,如3:00读作“three o’clock”。

  如果m不为0,则将时读出来,然后将分读出来,如5:30读作“five thirty”。

  时和分的读法使用的是英文数字的读法,其中0~20读作:

  0:zero, 1: one, 2:two, 3:three, 4:four, 5:five, 6:six, 7:seven, 8:eight, 9:nine, 10:ten, 11:eleven, 12:twelve, 13:thirteen, 14:fourteen, 15:fifteen, 16:sixteen, 17:seventeen, 18:eighteen, 19:nineteen, 20:twenty。

  30读作thirty,40读作forty,50读作fifty。

  对于大于20小于60的数字,首先读整十的数,然后再加上个位数。如31首先读30再加1的读法,读作“thirty one”。

  按上面的规则21:54读作“twenty one fifty four”,9:07读作“nine seven”,0:15读作“zero fifteen”。

输入格式

  输入包含两个非负整数h和m,表示时间的时和分。非零的数字前没有前导0。h小于24,m小于60。

输出格式

  输出时间时刻的英文。

样例输入

0 15

样例输出

zero fifteen

这类题可以用常量数组

#include<iostream>
#include<string>
using namespace std;
string time[]={"zero","one", "two","three","four","five","six","seven","eight","nine","ten",
"eleven","twelve","thirteen","fourteen","fifteen","sixteen","seventeen","eighteen","nineteen","twenty",
"thirty","forty","fifty"};
int main()
{
int h,m,m1,m2;
cin>>h>>m;
if(h<=20)
cout<<time[h];
else
cout<<time[20]<<" "<<time[h-20];
if(m==0)
cout<<" o'clock";
else
if(m<=20)
cout<<" "<<time[m];
else
cout<<" "<<time[m/10+18]<<" "<<time[m%10];
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: