您的位置:首页 > 编程语言 > Java开发

sdut_java_简单枚举类型——植物与颜色

2017-03-31 20:22 375 查看


简单枚举类型——植物与颜色

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 


Input

 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。


Output

 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 


Example Input

blue
yellow
purple



Example Output

Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.



Hint

 请用枚举类型实现。
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner in = new Scanner (System.in);
while( in.hasNext() ){
String str = in.nextLine();
color c = new color(str);
c.print();
}
in.close();
}

}

class color {

String col;

public color (String str) {
this.col = str;
}

public void print(){
if( col.equals("blue"))
System.out.println("Bluebells are blue.");
else if(col.equals("yellow"))
System.out.println("Sunflower are yellow.");
else if(col.equals("red"))
System.out.println("Rose are red.");
else if(col.equals("orange"))
System.out.println("Poppies are orange.");
else if(col.equals("green"))
System.out.println("Grass are green.");
else if(col.equals("violet"))
System.out.println("Violets are violet.");
else
System.out.println("I don't know about the color "+col +".");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: