您的位置:首页 > 其它

1005. Spell It Right (20)

2017-03-31 18:57 281 查看


1005. Spell It Right (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345

Sample Output:
one five

分析题意:给一个非负整数n,计算n的各位数字之和sum,sum的每一位上的数字用英文单词输出,注意输出格式,相怜的两个连续单词用空格隔开,最后一个没有额外的空格
由题意知N (<= 10100),所以定义一个不超105的字符数组即可,注意一个坑点哟,当sum=0时,输出zero

AC参考代码:
#include<iostream>

#include<cstdio>

#include<stdio.h>

#include<algorithm>

#include<cstring>

#include<string.h>

using namespace std;

char *str[11]={"zero","one","two","three","four","five","six","seven","eight","nine"};

int main()

{

        char a[105];

        while(gets(a))

        {

                int len=strlen(a);

                int sum=0;

                for(int i=0;i<len;i++)

                {

                        sum+=a[i]-'0';

                }

                if(sum==0)

                {

                        printf("zero\n");

                        continue;

                }

                int a[105];

                int r=0;

                while(sum)

                {

                        a[r++]=sum%10;

                        sum/=10;

                }

               
4000
for(int i=r-1;i>=0;i--)

                {

                        int x=a[i];

                        printf("%s",str[x]);

                        if(i!=0)

                                printf(" ");

                }

                printf("\n");

        }

        return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: