您的位置:首页 > 其它

1004. Counting Leaves (30)

2017-03-31 18:01 351 查看


1004. Counting Leaves (30)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end
of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.
Sample Input
2 1
01 1 02

Sample Output

0 1

分析题意:

输入:第一行输入两个数n和m,n代表树的节点个数,m代表非叶子节点的个数,紧接着输入n行数据,每一行数据的第一个数代表的是非叶子节点,然后输入k,表示有孩子,依次输入孩子

输出:依次输出每一层叶子节点的树目

解题思路:

由于n小于100,所以可以考虑用矩阵链表哟,利用dfs深度搜索,同时记录深度变量的进行统计哟

AC解题代码:

#include<stdio.h>

using namespace std;

int mat[105][105];

int num[105];

int n,m;

int maxdep=-1;

void dfs(int id, int dep)

{

        int flag=1;

        for(int i=1;i<=n;i++)

        {

                if(mat[id][i])

                {

                        flag=0;

                        dfs(i,dep+1);

                }

        }

        if(flag)

        {

                num[dep]++;

                if(dep>maxdep)

                        maxdep=dep;

        }

}

int main()

{

        scanf("%d%d",&n,&m);

        for(int i=0;i<m;i++)

        {

                int root,k,child;

                scanf("%d%d",&root,&k);

                for(int j=0;j<k;j++)

                {

                        scanf("%d",&child);

                        mat[root][child]=1;

                }

        }

        dfs(1,0);

        for(int i=0;i<=maxdep;i++)

        {

                printf("%d",num[i]);

                if (i!=maxdep)

                        printf(" ");

        }

        return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: