您的位置:首页 > 其它

PAT1005. Spell It Right (20)

2017-03-31 14:09 183 查看
题目如下:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345

Sample Output:
one five


这题意思就是给一个数字,求出各位数字的和,然后用英文输出。因为数字的大小为小于等于10的100次方,所以直接用字符串来读取该数字,然后每位相加求出和,再利用栈就如同PAT1001一样将每位分离出来,最后分别输出即可,很简单,代码如下:

#include <iostream>
#include <string>
#include <stack>
using namespace std;
int main()
{
int sum = 0;
int digit;
string s;
stack <int> sta;
cin >> s;
for (int i = 0;i < s.size();i++)
{
sum += s[i] - ('1' - 1);
}

do {
digit = sum % 10;
sta.push(digit);
sum /= 10;
} while (sum != 0);

if (!sta.empty())
{
switch (sta.top())
{
case 1:
cout << "one";
break;
case 2:
cout << "two";
break;
case 3:
cout << "three";
break;
case 4:
cout << "four";
break;
case 5:
cout << "five";
break;
case 6:
cout << "six";
break;
case 7:
cout << "seven";
break;
case 8:
cout << "eight";
break;
case 9:
cout << "nine";
break;
case 0:
cout << "zero";
break;
default:
break;
}
sta.pop();
}

while (!sta.empty())
{
switch (sta.top())
{
case 1:
cout << " one";
break;
case 2:
cout << " two";
break;
case 3:
cout << " three";
break;
case 4:
cout << " four";
break;
case 5:
cout << " five";
break;
case 6:
cout << " six";
break;
case 7:
cout << " seven";
break;
case 8:
cout << " eight";
break;
case 9:
cout << " nine";
break;
case 0:
cout << " zero";
break;
default:
break;
}
sta.pop();
}
}一次通过,没有什么问题。再去网上看了下别人的做法,可以改进的地方是将英文的1到10全部放入到一个数组中,这样代码比较简便。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT