您的位置:首页 > 产品设计 > UI/UE

POJ-----3061---Subsequence---尺取法

2017-03-30 21:42 246 查看
Subsequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13982 Accepted: 5908
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum
of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The
input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3

尺取法即是用来求一个序列最短的子串长度,且这个子串所有元素之和大于等于一个值

取左端点为序列最左侧的点,然后右端点依次向右取,当所有元素的值大于规定值时,更新最短子串长度,左端点向右移动一位,依次进行下去即可

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<queue>
#include<cmath>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long  LL;
const int maxn = 1e5+10;
const int mod = 1e9+7;
int s[maxn];
int main(){
int t, n, k, ans, sum;
cin >> t;
while(t--){
cin >> n >> k;
for(int i = 0; i < n; i++) cin >> s[i];
int i, j;
i = j = sum = 0;
ans = n+1;
while(1){
while(j < n && sum <= k) sum += s[j++];
if(sum < k) break;
ans = min(j-i, ans);
sum -= s[i++];
}
if(ans > n) ans = 0;
cout << ans;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: