您的位置:首页 > 其它

POJ 3280 Cheapest Palindrome

2017-03-30 21:07 330 查看
题目链接

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single
string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet ofN (1 ≤
N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two
different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards).
Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding
a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting
or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs
can be added to a string.

Input
Line 1: Two space-separated integers: N andM

Line 2: This line contains exactly M characters which constitute the initial ID string

Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output
900

Hint
If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 +
350 = 900, which is the minimum. 

定义dp[i][j]表示字符串的子串s[i...j]从i到j之间构成一个回文串需要的最小花费。

dp[i][j]=min(dp[i+1][j]+cost[s[i]-'a'],//比i...j少了一个首字母s[i+1...j]
dp[i][j-1]+cost[s[j]-'a']);//比i...j少了一个尾字母s[i...j-1]
if(s[i]==s[j])//首尾字母相同不用添加
dp[i][j]=min(dp[i][j],dp[i+1][j-1]);


其实添加一个字母和删除一个字母没有什么本质的区别,那个花费小就选择那一个。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int dp[2010][2010],cost[40];
char s[100010];
int main()
{
int i,j,n,m;
while(~scanf("%d%d",&n,&m))
{
memset(dp,0,sizeof(dp));
memset(cost,INF,sizeof(cost));
scanf("%s",s);
char c;
int add_cost,delete_cost;
for(i=0; i<n; i++)
{
getchar();
scanf("%c%d%d",&c,&add_cost,&delete_cost);
cost[c-'a']=min(add_cost,delete_cost);
}
for(i=m-1; i>=0; i--)
{
for(j=i+1; j<m; j++)
{
dp[i][j]=min(dp[i+1][j]+cost[s[i]-'a'],//比i...j少了一个首字母s[i+1...j]
dp[i][j-1]+cost[s[j]-'a']);//比i...j少了一个尾字母s[i...j-1]
if(s[i]==s[j])//首尾字母相同不用添加
dp[i][j]=min(dp[i][j],dp[i+1][j-1]);

}
}
printf("%d\n",dp[0][m-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: