您的位置:首页 > 其它

POJ 3666 Making the Grade

2017-03-30 20:00 393 查看
Description

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add
and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤
N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of
N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence
B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

|A1 - B1| + |A2
- B2| + ... + |AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single integer elevation:
Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input
7
1
3
2
4
5
3
9

Sample Output
3

如果改动的话,一定要与端点值相等。
所以dp[i][j]表示对于前i个,最大值是j的最小花费。
dp[i][j]=min{dp[i-1][k]}+abs(j-w[i])(1=<k<=j)
mn可以在循环中顺便求出。
由于w值较大,n较小,所以离散化。

#include<algorithm>
#include<iostream>
#include<cstdio>
using namespace std;
const int N=2005;
int n;
long long a
,b
,dp

;
long long ab(long long x)
{
return (x<0)?(-x):x;
}
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%lld",&a[i]);
b[i]=a[i];
}
sort(b+1,b+n+1);
for(int i=1;i<=n;i++)
{
long long mn=dp[i-1][1];
for(int j=1;j<=n;j++)
{
mn=min(mn,dp[i-1][j]);
dp[i][j]=mn+ab(a[i]-b[j]);
}
}
printf("%lld\n",*min_element(dp
+1,dp
+n+1));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划