您的位置:首页 > 其它

PAT - 甲级 - 1020. Tree Traversals (25)(层次遍历)

2017-03-30 09:59 423 查看
题目描述:

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers
in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:
4 1 6 3 5 7 2


题目思路:

dfs从根节点递归左右子树,记录每个结点层次遍历的对应坐标,最后遍历输出即可。

题目代码:

#include <cstdio>
#include <cstring>
using namespace std;

int n;
int pod[35];
int iod[35];
int lod[10000];

void dfs(int p1, int p2, int q1, int q2, int od){
if(p1 > p2 || q1 > q2) return ;

int i = p1;
while(iod[i] != pod[q2]) i++;
lod[od] = pod[q2];

dfs(p1, i-1, q1, q1+i-1-p1, 2*od);
dfs(i+1, p2, q1+i-p1, q2-1, 2*od+1);
}

int main(){
scanf("%d",&n);
memset(lod,0,sizeof(lod));
for(int i = 0; i < n; i++){
scanf("%d",&pod[i]);
}
for(int i = 0; i < n; i++){
scanf("%d",&iod[i]);
}
dfs(0, n-1, 0, n-1, 1);

int flag = 1;
for(int i = 1; i < 10000; i++){
if(flag && lod[i] != 0){
printf("%d",lod[i]);
flag = 0;
}
else if(!flag && lod[i]){
printf(" %d",lod[i]);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: