您的位置:首页 > 其它

HDU1061 Rightmost Digit

2017-03-30 08:34 302 查看


Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 54760    Accepted Submission(s): 20738


Problem Description

Given a positive integer N, you should output the most right digit of N^N.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

Output

For each test case, you should output the rightmost digit of N^N.

 

Sample Input

2
3
4

 

Sample Output

7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

      快速幂的模板,每次乘法完成后求余即可。  

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
int t;
long long int n;
cin>>t;
while(t--){
cin>>n;
int ans = 1,a = n;
n = n%10;
while(a>0){
if(a&1)
ans = (ans*n)%10;
a=a>>1;
n=(n*n)%10;
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学 快速幂