您的位置:首页 > 其它

hdu 1520 Anniversary party [树形dp入门]【动态规划】

2017-03-29 23:29 381 查看
题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=1520

————————————————————————————————————————————

Anniversary party

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10549 Accepted Submission(s): 4415

Problem Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:

L K

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line

0 0

Output

Output should contain the maximal sum of guests’ ratings.

Sample Input

7

1

1

1

1

1

1

1

1 3

2 3

6 4

7 4

4 5

3 5

0 0

Sample Output

5

————————————————————————————————————————————

题意:

一个树,每个节点有一个权值,这些节点不能拿挨着的,

一些节点会获得他们的权值,问你最大的权值和是多少

解题思路:

树形dp的入门题目

很容易想,

dp
[2]

其中dp[u][0],代表不选节点u的最大权值和 ,

dp[u][1]代表选节点u的最大权值和 ,

转移就是

dp[fa][0]=max(dp[u][0],dp[u][1])

dp[fa][1]=dp[u][0];

很好想.

附本题代码

————————————————————————————————————————————

#include <bits/stdc++.h>

using namespace std;
typedef long long int LL;

#define lowbit(x) (x&-x)
#define abs(x) ((x)>0?(x):-(x))
const int N = 10000+10;

vector<int >G
;

void add(int u,int v){
G[u].push_back(v);
G[v].push_back(u);
}

int dp
[2],w
,n;

void dfs(int u,int fa){

dp[u][1]=w[u];
dp[u][0]=0;

int gz=G[u].size();
for(int i=0,to;i<gz;i++){
to = G[u][i];
if(to==fa) continue;
dfs(to,u);
dp[u][0]+=max(dp[to][1],dp[to][0]);
dp[u][1]+=dp[to][0];
}
}

void init(){
for(int i=0;i<=n;i++)
G[i].clear();
}

int main(){
while(~scanf("%d",&n)&&n){
init();
for(int i=1;i<=n;i++) scanf("%d",&w[i]);

for(int u,v;true;){
scanf("%d%d",&u,&v);
if(u==v&&0==v) break;
add(u,v);
}
dfs(1,0);

printf("%d\n",max(dp[1][1],dp[1][0]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: